Menu

Star on GitHub · 3.4k

CVE-2026-91159

7.7 · HIGH

Discourse is an open-source discussion platform.

Published Oct 14, 2026CWE-79EPSS 0.42%

Overview

CVE-2026-91159 is a high-severity vulnerability. It was published on October 14, 2026 and has a CVSS 3.1 base score of 7.7 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

Technical description

Discourse is an open-source discussion platform. Prior to 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9, oEmbed processing treated an entire attacker-controlled HTML fragment as trusted when the fragment contained an iframe whose source matched the configured allowlist. A user with posting permission who controlled a public webpage and its oEmbed response could combine an allowlisted iframe with unrelated sibling HTML or CSS, causing stored visual overlays or other styled content to appear in post content and enabling misleading or fraudulent user interfaces. Exploitation requires a posting account, control of the fetched webpage and oEmbed response, and an allowlisted iframe source. The issue affects content integrity but does not expose restricted data, disrupt availability, or require interaction with Discourse Content Security Policy. This issue is fixed in versions 2026.9.0, 2026.8.1, 2026.7.3, and 2026.1.9.

Remediation

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Frequently asked questions

What is CVE-2026-91159?

CVE-2026-91159 is a high-severity vulnerability. It was published on October 14, 2026 and has a CVSS 3.1 base score of 7.7 (HIGH).

How severe is CVE-2026-91159?

This vulnerability has a CVSS 3.1 base score of 7.7, rated HIGH. It can be exploited remotely over the network. Some level of privileges is required for exploitation.

How do I fix or remediate CVE-2026-91159?

Check the references section for vendor advisories, patches, and mitigation guidance. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-91159?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-91159 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →