Menu

Star on GitHub · 3.4k

CVE-2026-95616

7.5 · HIGH

An integer overflow in WSS4J's DER bounds check lets an oversized allocation pass validation.

Published Sep 30, 2026apacheCWE-190EPSS 0.41%

Overview

CVE-2026-95616 is a high-severity vulnerability affecting apache wss4j. It was published on September 30, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

An integer overflow in WSS4J's DER bounds check lets an oversized allocation pass validation. An unauthenticated attacker can send a SOAP message carrying an X.509 certificate whose SubjectKeyIdentifier extension declares a length of 0x7FFFFFFF; WSS4J decodes this while resolving the signature's key reference, before the message is authenticated, so an eleven-byte extension triggers a 2 GB allocation. Repeated requests exhaust server memory.

Users are recommended to upgrade to versions 4.0.2 or 3.0.6 or 2.4.4, which fix this issue.

Remediation

Check the references section for vendor advisories and patches from apache. Update wss4j to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
apachewss4j>= 0, < 2.4.4Affected

Frequently asked questions

What is CVE-2026-95616?

CVE-2026-95616 is a high-severity vulnerability affecting apache wss4j. It was published on September 30, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-95616?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-95616?

Check the references section for vendor advisories and patches from apache. Update wss4j to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-95616?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-95616 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →