Menu

Star on GitHub · 3.4k

CVE-2026-95845

7.5 · HIGH

Moquette is a lightweight Java MQTT broker.

Published Sep 23, 2026moquetteCWE-770EPSS 0.41%

Overview

CVE-2026-95845 is a high-severity vulnerability affecting moquette moquette. It was published on September 23, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

Technical description

Moquette is a lightweight Java MQTT broker. Prior to 0.18.1, the broker does not enforce a maximum length for pending per-session message queues. When a fast publisher sends messages to a slow subscriber whose in-flight window is full, queued messages can accumulate without bound in memory or persistent storage. Remote clients can use this condition to exhaust broker resources and cause a denial of service. This issue is fixed in version 0.18.1.

Remediation

Check the references section for vendor advisories and patches from moquette. Update moquette to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

Affected products

VendorProductVersionsStatus
moquettemoquette>= 0, < 0.18.1Affected

Frequently asked questions

What is CVE-2026-95845?

CVE-2026-95845 is a high-severity vulnerability affecting moquette moquette. It was published on September 23, 2026 and has a CVSS 3.1 base score of 7.5 (HIGH).

How severe is CVE-2026-95845?

This vulnerability has a CVSS 3.1 base score of 7.5, rated HIGH. It can be exploited remotely over the network. No authentication or special privileges are required for exploitation.

How do I fix or remediate CVE-2026-95845?

Check the references section for vendor advisories and patches from moquette. Update moquette to the latest patched version. If immediate patching is not possible, review the CVSS vector to understand the attack surface and apply compensating controls such as network segmentation or access restrictions.

How can CyberStrike help with CVE-2026-95845?

CyberStrike is an open-source, AI-augmented pentesting engine. Rather than flag a version number, it tests whether an issue like CVE-2026-95845 is actually reachable in your own applications and APIs, then verifies each finding before reporting it. That tells you if the weakness is a real, exploitable risk in your environment or a false positive you can safely deprioritize.

Related HIGH CVEs from 2026

View all
Watch the demo →